The web site specified is already linked to another project

I ran into this issue whilst visiting a client this week, which I haven’t seen before. When the user tried to manually associate a project schedule with the workspace via Server Settings > Operational Policies > Project Workspaces , they would get this error:

The web site specified is already linked to another project

After verifying the workspace was not linked to an existing project, I turned my attention to the the project workspace template that we were trying to associate.  After a bit of searching around, it seems that the issue was caused by the site template used to create the project workspace being based on an existing site that was associated with a project schedule when it was saved. 

In order to fix the issue, it was necessary to:

  • Create a new Project site with the out of the box Project Workspace template;
  • Reapply any customisations;
  • Save the workspace into a new template;
  • Create a site using the new template
  • Associate the site with the schedule;
  • Migrate the contents from the old site to the new one;
  • Delete the old site.

Finally, the default project workspace template was updated to reflect the new fixed template using STSADM –o addtemplate  and changing the Project Workspace Provisioning Settings.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s